Remove these ads,
become a Club Member

Results 1 to 9 of 9

Thread: Turbo Elbow

          
   
  1. #1
    Club Guest
    Join Date
    Apr 2008
    Location
    WA
    Posts
    177
    Vehicle
    RPS13

    Turbo Elbow

    I have a chirping noise coming under the hood under full boost and pretty sure its my turbo elbow not fully secure. I messed with the bolts in a attempt to get the turbo heat shield off and I couldn't get them loose (got like some crazy factory locktite or something). I don't have really any tools that make it easy to get back behind the turbo and remove the bolts, plus I don't want to mess up my O2 sensor.

    Anyone have experience taking the elbow off and putting it on again. Is it easier to remove the whole turbo/exhaust manifold setup? Or can it all be done under the hood. Not an easy spot to work in, with the elbow so close to the firewall. Any special tools you guys use?

  2. #2
    Club Guest Sthirtizzle's Avatar
    Join Date
    Feb 2004
    Location
    Seattle
    Age
    31
    Posts
    345
    Vehicle
    ps13(stolen),S14,08 Fit
    Chirping or rattling? Heat shield bolts are probably rusted to shit. You kind of need to get that off in order to see what is wrong, try using pb blaster, if that doesn't work you might have to break them off. Could also be turbo coming loose from manifold, that has happened to me 3 times, twice with my s13 and once with my s14. See if you can feel with your hands, when cold, to see if any of the bolts are loose. Turbo elbow bolts are not too hard to get to except for the bottom one, but if it's the manifold you have to take the entire manifold off to get at the back nuts, it's a pain in the ass, if it is the manifold/turbo make sure and use the tabs that should be there, they are metal, and fold down on to the nut so the nut doesn't come loose.

  3. #3
    Club Guest
    Join Date
    Apr 2008
    Location
    WA
    Posts
    177
    Vehicle
    RPS13
    Its more of like a repeating bird chirpping noise when on WOT and when boost comes on. I tried starting up the car and running it to see if I could feel any puffs of air coming from either the manifold or the elbow, and I can't feel a thing. I was going to take off the elbow since the bolts are what I messed with trying to take off the turbo heat shield.

  4. #4
    Club Guest
    Join Date
    Dec 2008
    Location
    Oregon
    Age
    28
    Posts
    914
    Vehicle
    1992 S13 Hatchback
    Tiny boost leak? maybe a loose coupler?

  5. #5
    On Vacation fraktal's Avatar
    Join Date
    Jan 2003
    Location
    RightWheelDrive
    Age
    31
    Posts
    1,953
    Vehicle
    2004 Forester XT
    Infractions
    0/1 (10)
    sounds more like the turbo is going bye-bye.

  6. #6
    Club Guest nightslider's Avatar
    Join Date
    Sep 2007
    Location
    bellingham
    Age
    29
    Posts
    436
    Vehicle
    s13 240sx 04 zx6r 636
    mine made the same noise at WOT right after i did the swap and it was a broken stud between the mani and turbo. if thats the case make sure you put it back together with new studs and use nice gaskets or youll be doing it several times. also make sure you use the tabs to secure the bolts..... enjukuracing.com has all the stuff to do it right and for a decent price
    Last edited by nightslider; 11-21-2009 at 03:46 PM. Reason: added site to get parts he'll need

  7. #7
    Club Guest
    Join Date
    Apr 2008
    Location
    WA
    Posts
    177
    Vehicle
    RPS13
    I posted the video before maybe some of you seen it, general consensus was a manifold leak or turbo elbow. I figure since the elbow was what I messed with before and now all the sudden it makes this noise. Just wanted to know what the best way is to tackle this problem or where to start. I hate digging into things I'm not suppose to.


  8. #8
    Club Guest
    Join Date
    Dec 2008
    Location
    Oregon
    Age
    28
    Posts
    914
    Vehicle
    1992 S13 Hatchback
    damn that dosnt sound good

  9. #9
    On Vacation fraktal's Avatar
    Join Date
    Jan 2003
    Location
    RightWheelDrive
    Age
    31
    Posts
    1,953
    Vehicle
    2004 Forester XT
    Infractions
    0/1 (10)
    Quote Originally Posted by SXIII View Post
    I posted the video before maybe some of you seen it, general consensus was a manifold leak or turbo elbow. I figure since the elbow was what I messed with before and now all the sudden it makes this noise. Just wanted to know what the best way is to tackle this problem or where to start. I hate digging into things I'm not suppose to.
    honestly at this point i would pull the entire manifold/turbo/elbow as one assembly. replace all the gaskets, studs, nuts and locking tabs. make sure everything is torqued to spec and reinstall. new hardware/gaskets never hurt and you shouldn't ever have to worry about leaks again if you do it correctly.

    screw enjuku. order from thenismoshop.com. WAY cheaper prices, straight from a nissan dealer and you only pay for shipping from CA, not FL.

Similar Threads

  1. it's ridiculous...
    By 8gti9 in forum Off-Topic and Miscellaneous
    Replies: 33
    Last Post: 07-13-2010, 03:30 PM
  2. FS: GReddy Turbo Elbow and Megan Racing Turbo Elbow [NJ]
    By twitchh17 in forum Parts and Accessories
    Replies: 2
    Last Post: 10-03-2009, 09:08 AM
  3. FS: Redtop Turbo Manifold and Elbow
    By TypeXDrifter in forum Parts and Accessories
    Replies: 2
    Last Post: 05-11-2009, 03:38 AM
  4. Turbo Elbow + DP install Questions on SR20....
    By Donuttrik in forum Technical Chat
    Replies: 3
    Last Post: 10-31-2006, 12:21 AM
  5. SOHC Turbo For Dummies
    By veilside180sx in forum Technical Chat
    Replies: 2
    Last Post: 09-27-2005, 11:00 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ukash