Remove these ads,
become a Club Member

Results 1 to 9 of 9

Thread: sr20det high idle

          
   
  1. #1
    Club Guest 240sxJon's Avatar
    Join Date
    Mar 2008
    Location
    sandpoint, Idaho
    Age
    23
    Posts
    12
    Vehicle
    s13 240sx coupe

    sr20det high idle

    hi my sr20det has a really high cold start idle. when i start it when its cold it idles at like 3000 rpms. i checks the tps and i had a bad coupler and changed that and still didnt fix the problem. after it warms up it will idle at like 1350 rpms and every once in a while idle down to 800.

  2. #2
    Club Guest
    Join Date
    Aug 2008
    Location
    WA
    Posts
    468
    Vehicle
    RHS13
    Have you tried cleaning the iacv/acc valve? Mine was all gunked up and had a nasty high idle before I cleaned it.

  3. #3
    Club Guest 240sxJon's Avatar
    Join Date
    Mar 2008
    Location
    sandpoint, Idaho
    Age
    23
    Posts
    12
    Vehicle
    s13 240sx coupe
    i have not tried that. but thats what aim going to do thanks.

  4. #4
    Club Guest 240sxJon's Avatar
    Join Date
    Mar 2008
    Location
    sandpoint, Idaho
    Age
    23
    Posts
    12
    Vehicle
    s13 240sx coupe
    should i take it out to clean it? or just spray carb cleaner down it?

  5. #5
    Club Guest
    Join Date
    Aug 2008
    Location
    WA
    Posts
    468
    Vehicle
    RHS13
    You can do it either way. I've sprayed carb cleaner in one on my KA. But I ended up removing it and cleaning it by hand, which worked 100x better.

  6. #6
    Club Guest 240sxJon's Avatar
    Join Date
    Mar 2008
    Location
    sandpoint, Idaho
    Age
    23
    Posts
    12
    Vehicle
    s13 240sx coupe
    Okay I will probably take it out then just wondering cause it's hard to get to on my sr

  7. #7
    Club Guest
    Join Date
    Aug 2008
    Location
    WA
    Posts
    468
    Vehicle
    RHS13
    You'll want to take the intake mani off.. I wouldn't try it without the mani off haha

  8. #8
    Club Guest 240sxJon's Avatar
    Join Date
    Mar 2008
    Location
    sandpoint, Idaho
    Age
    23
    Posts
    12
    Vehicle
    s13 240sx coupe
    well i got it off cleaned it and nothing changed. i think im gonna check all my couplers and stuff.

  9. #9
    On Vacation
    Join Date
    Jun 2011
    Location
    Canada
    Posts
    60
    Vehicle
    s13
    A raccoon laid a baby in it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ukash